summaryrefslogtreecommitdiff
path: root/Services/WebContent/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2020-06-17 17:31:42 +0200
committerAndreas Kling <kling@serenityos.org>2020-06-17 20:09:44 +0200
commitc45c5ded342b9c530207222bd620f4ee0d4af601 (patch)
treed618d658e770286139bad37222a8cf68e8669e61 /Services/WebContent/CMakeLists.txt
parentde12cf6821679c900ced1c8164741bfefbde97b0 (diff)
downloadserenity-c45c5ded342b9c530207222bd620f4ee0d4af601.zip
WebContent: Start work on browser process separation :^)
The "WebContent" service provides a very restricted instance of LibWeb running as an unprivileged user account. This will be used to implement process separation in Browser, among other things. This first cut of the service only spawns a single WebContent process when someone connects to /tmp/portal/webcontent. We will soon switch this over to spawning a new process for each connection. Since this feature is very immature, we'll be bringing it up inside of Demos/WebView as a separate demo program. Eventually this will become a reusable widget that anyone can embed and easily get out-of-process web content in their GUI. This is pretty, pretty cool! :^)
Diffstat (limited to 'Services/WebContent/CMakeLists.txt')
-rw-r--r--Services/WebContent/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Services/WebContent/CMakeLists.txt b/Services/WebContent/CMakeLists.txt
new file mode 100644
index 0000000000..a7e367ff94
--- /dev/null
+++ b/Services/WebContent/CMakeLists.txt
@@ -0,0 +1,13 @@
+compile_ipc(WebContentServer.ipc WebContentServerEndpoint.h)
+compile_ipc(WebContentClient.ipc WebContentClientEndpoint.h)
+
+set(SOURCES
+ ClientConnection.cpp
+ main.cpp
+ PageHost.cpp
+ WebContentServerEndpoint.h
+ WebContentClientEndpoint.h
+)
+
+serenity_bin(WebContent)
+target_link_libraries(WebContent LibCore LibIPC LibGfx LibWeb)