summaryrefslogtreecommitdiff
path: root/Services/NotificationServer/CMakeLists.txt
diff options
context:
space:
mode:
authorSergey Bugaev <bugaevc@serenityos.org>2020-05-06 18:40:06 +0300
committerAndreas Kling <kling@serenityos.org>2020-05-14 20:15:18 +0200
commit450a2a0f9ce2443bc06445ee018c9860d8cd5fc8 (patch)
treec124a612ef259b764855af5e33c39e0d09ad4df2 /Services/NotificationServer/CMakeLists.txt
parent49727ffee424d8c0038ce18b91b0bf0ff33b1a4d (diff)
downloadserenity-450a2a0f9ce2443bc06445ee018c9860d8cd5fc8.zip
Build: Switch to CMake :^)
Closes https://github.com/SerenityOS/serenity/issues/2080
Diffstat (limited to 'Services/NotificationServer/CMakeLists.txt')
-rw-r--r--Services/NotificationServer/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Services/NotificationServer/CMakeLists.txt b/Services/NotificationServer/CMakeLists.txt
new file mode 100644
index 0000000000..a28d9f16a5
--- /dev/null
+++ b/Services/NotificationServer/CMakeLists.txt
@@ -0,0 +1,13 @@
+compile_ipc(NotificationServer.ipc NotificationServerEndpoint.h)
+compile_ipc(NotificationClient.ipc NotificationClientEndpoint.h)
+
+set(SOURCES
+ ClientConnection.cpp
+ main.cpp
+ NotificationWindow.cpp
+ NotificationServerEndpoint.h
+ NotificationClientEndpoint.h
+)
+
+serenity_bin(NotificationServer)
+target_link_libraries(NotificationServer LibGUI LibIPC)