summaryrefslogtreecommitdiff
path: root/Meta/Lagom/Tools/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaster <akaster@serenityos.org>2022-07-04 08:48:19 -0600
committerAndreas Kling <kling@serenityos.org>2022-07-06 14:24:23 +0200
commit2b29e611fe278059ac8d2f996eb331ff429ca3b3 (patch)
tree242ccb4641625b1cd68ef2933382ca079dc11ce6 /Meta/Lagom/Tools/CMakeLists.txt
parent02e8f2956014bd17c4e5a68757776fffc6d43c51 (diff)
downloadserenity-2b29e611fe278059ac8d2f996eb331ff429ca3b3.zip
Meta: Rename Lagom library target names from LagomFoo to LibFoo
This matches the target names for the main serenity build, and will make simplifying the Lagom build much easier going forward. The LagomFoo name came from a time when we had both library builds in the same CMake generated project and needed to deconflict the names.
Diffstat (limited to 'Meta/Lagom/Tools/CMakeLists.txt')
-rw-r--r--Meta/Lagom/Tools/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Meta/Lagom/Tools/CMakeLists.txt b/Meta/Lagom/Tools/CMakeLists.txt
index 088e0aaaa5..e81eff13de 100644
--- a/Meta/Lagom/Tools/CMakeLists.txt
+++ b/Meta/Lagom/Tools/CMakeLists.txt
@@ -3,7 +3,7 @@ function(lagom_tool tool)
add_executable(${tool} ${SOURCES} ${LAGOM_TOOL_SOURCES})
# alias for parity with exports
add_executable(Lagom::${tool} ALIAS ${tool})
- target_link_libraries(${tool} LagomCore ${LAGOM_TOOL_LIBS})
+ target_link_libraries(${tool} LibCore ${LAGOM_TOOL_LIBS})
install(
TARGETS ${tool}
EXPORT LagomTargets