summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2022-05-14 15:07:12 +0200
committerLinus Groh <mail@linusgroh.de>2022-05-14 17:53:06 +0200
commitee721978f68ffd3b836fafaecf452f969bbee991 (patch)
treed7a5856bcf2e98537abefca56dcd9a1000a8a42f /Meta/Lagom/CMakeLists.txt
parent4472cab81ac6f24dd1425153b05b24ef424c760a (diff)
downloadserenity-ee721978f68ffd3b836fafaecf452f969bbee991.zip
Meta: Move compiler flags into standalone CMake files
This way we can have all of them in a single place, similar to how we structure options added via the serenity_option() macro.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt17
1 files changed, 1 insertions, 16 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 76b632a163..94ee50a227 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -60,22 +60,7 @@ if (ENABLE_FUZZERS_LIBFUZZER OR ENABLE_FUZZERS_OSSFUZZ)
endif()
include(wasm_spec_tests)
-
-add_compile_options(-fsigned-char)
-add_compile_options(-Wno-unknown-warning-option -Wno-literal-suffix -Wno-implicit-const-int-float-conversion)
-add_compile_options(-O2)
-add_compile_options(-Wall -Wextra -Werror)
-add_compile_options(-fPIC -g)
-add_compile_options(-Wno-maybe-uninitialized)
-add_compile_options(-fno-exceptions)
-add_compile_options(-fdiagnostics-color=always)
-if (NOT ENABLE_FUZZERS)
- add_compile_options(-fno-semantic-interposition)
-endif()
-
-set(CMAKE_CXX_STANDARD 20)
-set(CMAKE_CXX_STANDARD_REQUIRED ON)
-set(CMAKE_CXX_EXTENSIONS OFF)
+include(lagom_compile_options)
include(GNUInstallDirs) # make sure to include before we mess w/RPATH