summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2021-01-03 19:18:24 +0100
committerAndreas Kling <kling@serenityos.org>2021-01-03 22:12:08 +0100
commitb36f57e5705a9db89e267608f9a1f8d9f8f640b8 (patch)
treecf2508fb81642c5fd7a5452df6ef33cbb0c74fee /Meta/Lagom/CMakeLists.txt
parent1e236d5863480a10620d6d079d0fd4682d3ebacc (diff)
downloadserenity-b36f57e5705a9db89e267608f9a1f8d9f8f640b8.zip
Lagom: Build gml-format
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index a8e60570f3..8685c5e19e 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -50,6 +50,8 @@ list(REMOVE_ITEM LIBELF_SOURCES "${CMAKE_CURRENT_SOURCE_DIR}/../../Libraries/Lib
file(GLOB LIBGEMINI_SOURCES CONFIGURE_DEPENDS "../../Libraries/LibGemini/*.cpp")
file(GLOB LIBGFX_SOURCES CONFIGURE_DEPENDS "../../Libraries/LibGfx/*.cpp")
+file(GLOB LIBGUI_GML_SOURCES CONFIGURE_DEPENDS "../../Libraries/LibGUI/GML*.cpp")
+list(REMOVE_ITEM LIBGUI_GML_SOURCES ../../Libraries/LibGUI/GMLSyntaxHighlighter.cpp)
file(GLOB LIBHTTP_SOURCES CONFIGURE_DEPENDS "../../Libraries/LibHTTP/*.cpp")
file(GLOB LIBIPC_SOURCES CONFIGURE_DEPENDS "../../Libraries/LibIPC/*.cpp")
file(GLOB LIBLINE_SOURCES CONFIGURE_DEPENDS "../../Libraries/LibLine/*.cpp")
@@ -65,14 +67,11 @@ file(GLOB LIBTLS_SOURCES CONFIGURE_DEPENDS "../../Libraries/LibTLS/*.cpp")
file(GLOB LIBTTF_SOURCES CONFIGURE_DEPENDS "../../Libraries/LibTTF/*.cpp")
file(GLOB SHELL_SOURCES CONFIGURE_DEPENDS "../../Shell/*.cpp")
file(GLOB SHELL_TESTS CONFIGURE_DEPENDS "../../Shell/Tests/*.sh")
-set(SHELL_MAIN_CPP "../../Shell/main.cpp")
-set(LIB_SHELL_SOURCES ${SHELL_SOURCES})
-list(REMOVE_ITEM LIB_SHELL_SOURCES ${SHELL_MAIN_CPP})
-set(SHELL_SOURCES ${SHELL_MAIN_CPP})
+list(REMOVE_ITEM SHELL_SOURCES ../../Shell/main.cpp)
set(LAGOM_REGEX_SOURCES ${LIBREGEX_LIBC_SOURCES} ${LIBREGEX_SOURCES})
set(LAGOM_CORE_SOURCES ${AK_SOURCES} ${LIBCORE_SOURCES})
-set(LAGOM_MORE_SOURCES ${LIBELF_SOURCES} ${LIBIPC_SOURCES} ${LIBLINE_SOURCES} ${LIBJS_SOURCES} ${LIBJS_SUBDIR_SOURCES} ${LIBX86_SOURCES} ${LIBCRYPTO_SOURCES} ${LIBCOMPRESS_SOURCES} ${LIBCRYPTO_SUBDIR_SOURCES} ${LIBTLS_SOURCES} ${LIBTTF_SOURCES} ${LIBMARKDOWN_SOURCES} ${LIBGEMINI_SOURCES} ${LIBGFX_SOURCES} ${LIBHTTP_SOURCES} ${LAGOM_REGEX_SOURCES} ${LIB_SHELL_SOURCES})
+set(LAGOM_MORE_SOURCES ${LIBELF_SOURCES} ${LIBIPC_SOURCES} ${LIBLINE_SOURCES} ${LIBJS_SOURCES} ${LIBJS_SUBDIR_SOURCES} ${LIBX86_SOURCES} ${LIBCRYPTO_SOURCES} ${LIBCOMPRESS_SOURCES} ${LIBCRYPTO_SUBDIR_SOURCES} ${LIBTLS_SOURCES} ${LIBTTF_SOURCES} ${LIBMARKDOWN_SOURCES} ${LIBGEMINI_SOURCES} ${LIBGFX_SOURCES} ${LIBGUI_GML_SOURCES} ${LIBHTTP_SOURCES} ${LAGOM_REGEX_SOURCES} ${SHELL_SOURCES})
include_directories (../../)
include_directories (../../Libraries/)
@@ -132,11 +131,17 @@ if (BUILD_LAGOM)
target_link_libraries(disasm_lagom Lagom)
target_link_libraries(disasm_lagom stdc++)
- add_executable(shell_lagom ${SHELL_SOURCES})
+ add_executable(shell_lagom ../../Shell/main.cpp)
set_target_properties(shell_lagom PROPERTIES OUTPUT_NAME shell)
target_link_libraries(shell_lagom Lagom)
target_link_libraries(shell_lagom stdc++)
target_link_libraries(shell_lagom pthread)
+
+ add_executable(gml-format_lagom ../../Userland/gml-format.cpp)
+ set_target_properties(gml-format_lagom PROPERTIES OUTPUT_NAME gml-format)
+ target_link_libraries(gml-format_lagom Lagom)
+ target_link_libraries(gml-format_lagom stdc++)
+
foreach(TEST_PATH ${SHELL_TESTS})
get_filename_component(TEST_NAME ${TEST_PATH} NAME_WE)
add_test(