summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2022-09-25 12:10:28 +0200
committerAndreas Kling <kling@serenityos.org>2022-09-25 12:10:28 +0200
commit34c232def735eed3ddbd2f5376acb5b627992c8f (patch)
treecb075d9a312a279c0df1eda79d62208251050121 /Meta/Lagom/CMakeLists.txt
parent5778da765dea67f613876d13df54fd9d241bc06d (diff)
downloadserenity-34c232def735eed3ddbd2f5376acb5b627992c8f.zip
Lagom: Build DOMTreeModel from LibWebView
This will be used in Ladybird.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 22f6be3baa..e680c708a9 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -577,6 +577,12 @@ if (BUILD_LAGOM)
LIBS LibCrypto LibTLS
)
+ # WebView
+ list(APPEND LIBWEBVIEW_SOURCES "../../Userland/Libraries/LibWebView/DOMTreeModel.cpp")
+ lagom_lib(WebView webview
+ SOURCES ${LIBWEBVIEW_SOURCES}
+ LIBS LibGUI)
+
# x86
# FIXME: Excluding arm64 is a temporary hack to circumvent a build problem
# for Lagom on Apple M1