summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorkleines Filmröllchen <filmroellchen@serenityos.org>2023-03-07 16:59:02 +0100
committerTim Flynn <trflynn89@pm.me>2023-03-13 12:35:17 -0400
commit0563048949031a28d0c3e06f046dfc8d77b5084e (patch)
tree09aa1a361a4e9fdcfe4461df6329ac2a59f10da1 /Meta/Lagom/CMakeLists.txt
parenta8963a270f09eb78d7cb6d23e1b9bd6c6dc734a1 (diff)
downloadserenity-0563048949031a28d0c3e06f046dfc8d77b5084e.zip
file: Read more metadata from audio files
We can always read the basic format information (sample rate, bit depth, etc.), but we will also print artist, album, and title if available in the metadata.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index a2d69e6030..b8196b67e8 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -492,7 +492,7 @@ if (BUILD_LAGOM)
if (NOT EMSCRIPTEN)
# LibELF is part of LibC in SerenityOS builds, but not in Lagom.
add_executable(file ../../Userland/Utilities/file.cpp)
- target_link_libraries(file LibCompress LibCore LibELF LibGfx LibIPC LibMain)
+ target_link_libraries(file LibAudio LibCompress LibCore LibELF LibGfx LibIPC LibMain)
endif()
add_executable(gml-format ../../Userland/Utilities/gml-format.cpp)