summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorNico Weber <thakis@chromium.org>2021-10-15 14:28:13 -0400
committerLinus Groh <mail@linusgroh.de>2021-10-15 21:59:42 +0100
commitec9488a58cb17cd660c2114881c449bbfa4e29de (patch)
treee1a20c98ac9ad3b48faa215b85d94ab0e664c1b2 /Meta/Lagom/CMakeLists.txt
parentb11d660ff82112a2a109dc4e764749c51449aec3 (diff)
downloadserenity-ec9488a58cb17cd660c2114881c449bbfa4e29de.zip
Lagom: Build with -fno-no-semantic-interposition
Lagom: Build with -fno-no-semantic-interposition We build with this in non-lagom builds, and serenity's gcc even adds it to its CC1_SPEC. Let's use it for lagom too. Reduces the number of dynamic relocations in liblagom-js.so.0.0.0 (per `objdump -R`) from 15133 to 14534, and increases its size back to 91M (95156800 bytes), probably due to more inlining being possible. This might help perf of lagom binaries.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index a6e401a59d..889c96845e 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -68,6 +68,7 @@ add_compile_options(-Wall -Wextra -Werror)
add_compile_options(-fPIC -g)
add_compile_options(-Wno-maybe-uninitialized)
add_compile_options(-fno-exceptions)
+add_compile_options(-fno-semantic-interposition)
set(CMAKE_CXX_STANDARD 20)
set(CMAKE_CXX_STANDARD_REQUIRED ON)