summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2020-03-23 13:15:32 +0100
committerAndreas Kling <kling@serenityos.org>2020-03-23 13:15:32 +0100
commite31dac3ba4985e940eaea0b6700a091aaaac4ced (patch)
tree6d164b521b7c3e97f8fe171ea1238ddd0e6afbd0 /Meta/Lagom/CMakeLists.txt
parent79e065f0a2aacb4b467cb091ec58e9cec53719f4 (diff)
downloadserenity-e31dac3ba4985e940eaea0b6700a091aaaac4ced.zip
Lagom: Build LibJS + "js" test program
You can now get a full Linux build of the "js" test program by simply building in Meta/Lagom :^)
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 38fa365895..8b98afadc9 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -12,8 +12,10 @@ endif()
file(GLOB AK_SOURCES "../../AK/*.cpp")
file(GLOB LIBCORE_SOURCES "../../Libraries/LibCore/*.cpp")
file(GLOB LIBIPC_SOURCES "../../Libraries/LibIPC/*.cpp")
+file(GLOB LIBJS_SOURCES "../../Libraries/LibJS/*.cpp")
+file(GLOB LIBJS_SUBDIR_SOURCES "../../Libraries/LibJS/*/*.cpp")
-set(SOURCES ${AK_SOURCES} ${LIBCORE_SOURCES} ${LIBIPC_SOURCES})
+set(SOURCES ${AK_SOURCES} ${LIBCORE_SOURCES} ${LIBIPC_SOURCES} ${LIBJS_SOURCES} ${LIBJS_SUBDIR_SOURCES})
include_directories (../../)
include_directories (../../Libraries/)
@@ -26,3 +28,8 @@ target_link_libraries(TestApp stdc++)
add_executable(TestJson TestJson.cpp)
target_link_libraries(TestJson lagom)
target_link_libraries(TestJson stdc++)
+
+add_executable(js ../../Userland/js.cpp)
+target_link_libraries(js lagom)
+target_link_libraries(js stdc++)
+target_link_libraries(js pthread)