summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2021-07-29 14:18:51 -0400
committerLinus Groh <mail@linusgroh.de>2021-07-30 21:26:31 +0100
commitd485cf29d7f90c640a6412fbfccdf4cde09e5d56 (patch)
treeb06fb97ac8ca2dae4b9b86e32e1e6cc55ec8024b /Meta/Lagom/CMakeLists.txt
parentf1dd770a8a710c086e357e6fb89a28e27795f998 (diff)
downloadserenity-d485cf29d7f90c640a6412fbfccdf4cde09e5d56.zip
LibRegex+LibUnicode: Begin implementing Unicode property escapes
This supports some binary property matching. It does not support any properties not yet parsed by LibUnicode, nor does it support value matching (such as Script_Extensions=Latin).
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 7c1a3c0cf2..6a55a6544f 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -319,6 +319,7 @@ if (BUILD_LAGOM)
file(GLOB LIBREGEX_SOURCES CONFIGURE_DEPENDS "../../Userland/Libraries/LibRegex/*.cpp")
lagom_lib(Regex regex
SOURCES ${LIBREGEX_SOURCES} ${LIBREGEX_LIBC_SOURCES}
+ LIBS LagomUnicode
)
# Shell