summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorTimothy Flynn <trflynn89@pm.me>2022-12-13 10:07:23 -0500
committerLinus Groh <mail@linusgroh.de>2022-12-14 15:24:48 +0000
commitd382e77d38cff6e833d6a59ff8c6179a2b3e6ad9 (patch)
tree5f9b77441c9048971e312a7a57a75865adb236e9 /Meta/Lagom/CMakeLists.txt
parente8dbb1a8b25ea7227b2521a406f7dac4a7abcae3 (diff)
downloadserenity-d382e77d38cff6e833d6a59ff8c6179a2b3e6ad9.zip
LibUnicode: Fix compilation when the UCD download is disabled
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 1ae5b7a725..40c9e4e4f7 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -432,7 +432,9 @@ if (BUILD_LAGOM)
# FIXME: LibLocaleData is an object lib in Lagom, because the weak symbol trick we use on serenity
# straight up isn't supposed to work per ELF rules
target_link_libraries(LibLocale PRIVATE LibTimeZone)
- install(TARGETS LibLocaleData EXPORT LagomTargets)
+ if (ENABLE_UNICODE_DATABASE_DOWNLOAD)
+ install(TARGETS LibLocaleData EXPORT LagomTargets)
+ endif()
add_serenity_subdirectory(Userland/Shell)