summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authordavidot <davidot@serenityos.org>2022-01-22 14:27:53 +0100
committerLinus Groh <mail@linusgroh.de>2022-01-25 23:26:14 +0000
commitb40308d0a4f6d228bbf01c1d5795967dce8df804 (patch)
tree59e1ae2063c0381225ed57c6aad06817a31aeb3b /Meta/Lagom/CMakeLists.txt
parentf06e7dd13f4384246954d24203520b127e7c3da2 (diff)
downloadserenity-b40308d0a4f6d228bbf01c1d5795967dce8df804.zip
Tests+LibJS: Add very simple bytecode LibJS tests
These tests are not meant as a replacement to test-js with the -b option but are meant to test simple cases until that works. Before this it was very easy to accidentally break bytecode since no tests were run in bytecode mode. This hopefully makes it easier to spot such regressions :^).
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 58f60dbb0a..3daf145601 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -604,8 +604,9 @@ if (BUILD_LAGOM)
)
set_tests_properties(JS PROPERTIES ENVIRONMENT SERENITY_SOURCE_DIR=${SERENITY_PROJECT_ROOT})
- # test-invalid-unicode-js
+ # Extra tests from Tests/LibJS
lagom_test(../../Tests/LibJS/test-invalid-unicode-js.cpp LIBS LagomJS)
+ lagom_test(../../Tests/LibJS/test-bytecode-js.cpp LIBS LagomJS)
# Markdown
include(commonmark_spec)