summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authordavidot <davidot@serenityos.org>2021-10-03 13:10:35 +0200
committerAndreas Kling <kling@serenityos.org>2021-10-03 17:42:05 +0200
commitac2c3a73b136787d5dad0e00a43c1fcbed8f1ff3 (patch)
tree0da429bab9e03696b5d4f22db1a94d9732e44b99 /Meta/Lagom/CMakeLists.txt
parent962298b04005f59e34d93b6db088e98efc8a3ba1 (diff)
downloadserenity-ac2c3a73b136787d5dad0e00a43c1fcbed8f1ff3.zip
LibJS: Add a specific test for invalid unicode characters in the lexer
Also fixes that it tried to make substrings past the end of the source if we overran the source length.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 847a7282cd..c0688f96df 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -528,6 +528,9 @@ if (BUILD_LAGOM)
)
set_tests_properties(JS PROPERTIES ENVIRONMENT SERENITY_SOURCE_DIR=${SERENITY_PROJECT_ROOT})
+ # test-invalid-unicode-js
+ lagom_test(../../Tests/LibJS/test-invalid-unicode-js.cpp LIBS LagomJS)
+
# Markdown
include(commonmark_spec)
file(GLOB LIBMARKDOWN_TEST_SOURCES CONFIGURE_DEPENDS "../../Tests/LibMarkdown/*.cpp")