summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaster <akaster@serenityos.org>2021-09-07 01:50:09 -0600
committerAli Mohammad Pur <Ali.mpfard@gmail.com>2021-09-15 19:04:52 +0430
commit6e7cc40b18dae594a9b0344a8dda692fa4d81343 (patch)
treef6b3ada9d733f09242d1b6278610c597115447c5 /Meta/Lagom/CMakeLists.txt
parenta269a32a17866641f057c8f52348c1c9b4b95d7b (diff)
downloadserenity-6e7cc40b18dae594a9b0344a8dda692fa4d81343.zip
Meta: Add Meta/CMake to the CMAKE_MODULE_PATH for Serenity and Lagom
This makes it so we don't need to specify the full path to all the helper scripts we include() from different places in the codebase and feels a lot cleaner.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 39cbdd17f9..f35a5d908c 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -24,6 +24,8 @@ get_filename_component(
ABSOLUTE CACHE
)
+list(APPEND CMAKE_MODULE_PATH "${SERENITY_PROJECT_ROOT}/Meta/CMake")
+
find_package(Threads REQUIRED)
if (ENABLE_LAGOM_CCACHE)
@@ -33,7 +35,7 @@ if (ENABLE_LAGOM_CCACHE)
endif()
endif()
-include(${SERENITY_PROJECT_ROOT}/Meta/CMake/wasm_spec_tests.cmake)
+include(wasm_spec_tests)
add_compile_options(-Wno-unknown-warning-option -Wno-literal-suffix -Wno-deprecated-copy)
add_compile_options(-O2)
@@ -378,7 +380,7 @@ if (BUILD_LAGOM)
# Unicode
# Don't include UnicodeData for Fuzzer builds, we didn't build the CodeGenerators
if (NOT ENABLE_OSS_FUZZ AND NOT ENABLE_FUZZER_SANITIZER)
- include(${SERENITY_PROJECT_ROOT}/Meta/CMake/unicode_data.cmake)
+ include(unicode_data)
else()
set(ENABLE_UNICODE_DATABASE_DOWNLOAD OFF)
endif()
@@ -519,7 +521,7 @@ if (BUILD_LAGOM)
set_tests_properties(JS PROPERTIES ENVIRONMENT SERENITY_SOURCE_DIR=${SERENITY_PROJECT_ROOT})
# Markdown
- include(${SERENITY_PROJECT_ROOT}/Meta/CMake/commonmark_spec.cmake)
+ include(commonmark_spec)
file(GLOB LIBMARKDOWN_TEST_SOURCES CONFIGURE_DEPENDS "../../Tests/LibMarkdown/*.cpp")
foreach(source ${LIBMARKDOWN_TEST_SOURCES})
lagom_test(${source} LIBS LagomMarkdown)