summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorAli Mohammad Pur <ali.mpfard@gmail.com>2022-03-26 21:32:57 +0430
committerAndreas Kling <kling@serenityos.org>2022-03-28 23:11:48 +0200
commit67357fe984c19b724c7171959c4b1a6101f9047a (patch)
treef8285be3fdbe2ff7f84bdc3e52c015d0bf81c17b /Meta/Lagom/CMakeLists.txt
parent06cedf5baee5d77b11f2d472a4ba934e4a6cb6c1 (diff)
downloadserenity-67357fe984c19b724c7171959c4b1a6101f9047a.zip
LibXML: Add a fairly basic XML parser
Currently this can parse XML and resolve external resources/references, and read a DTD (but not apply or verify its rules). That's good enough for _most_ XHTML documents as the HTML 5 spec enforces its own rules about document well-formedness, and does not make use of XML DTDs (aside from a list of predefined entities). An accompanying `xml` utility is provided that can read and dump XML documents, and can also run the XML conformance test suite.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 6d1b0a8a28..3ab41d441d 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -478,6 +478,10 @@ if (BUILD_LAGOM)
)
endif()
+ file(GLOB LIBXML_SOURCES CONFIGURE_DEPENDS "../../Userland/Libraries/LibXML/*/*.cpp")
+ lagom_lib(XML xml
+ SOURCES ${LIBXML_SOURCES})
+
if (NOT ENABLE_OSS_FUZZ AND NOT ENABLE_FUZZER_SANITIZER AND NOT ENABLE_COMPILER_EXPLORER_BUILD)
# Lagom Examples
add_executable(TestApp TestApp.cpp)
@@ -523,6 +527,10 @@ if (BUILD_LAGOM)
set_target_properties(wasm_lagom PROPERTIES OUTPUT_NAME wasm)
target_link_libraries(wasm_lagom LagomCore LagomWasm LagomLine LagomMain)
+ add_executable(xml_lagom ../../Userland/Utilities/xml.cpp)
+ set_target_properties(xml_lagom PROPERTIES OUTPUT_NAME xml)
+ target_link_libraries(xml_lagom LagomCore LagomXML LagomMain)
+
enable_testing()
# LibTest
file(GLOB LIBTEST_SOURCES CONFIGURE_DEPENDS "../../Userland/Libraries/LibTest/*.cpp")