summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrew Kaster <andrewdkaster@gmail.com>2021-02-28 12:47:48 -0700
committerAndreas Kling <kling@serenityos.org>2021-03-01 11:12:36 +0100
commit669b6c43aac49df306f548d9e2b518539e7a1369 (patch)
treef503cc56abe9e99349290d87d1d756bc83af8aae /Meta/Lagom/CMakeLists.txt
parent5b1edc0678219f49ae4fb22c98fbc20705a43957 (diff)
downloadserenity-669b6c43aac49df306f548d9e2b518539e7a1369.zip
AK/Lagom: Modify TestSuite to return how many tests failed from main
This allows us to remove the FAIL_REGEX logic from the CTest invocation of AK and LibRegex tests, as they will return a non-zero exit code on failure :^). Also means that running a failing TestSuite-enabled test with the run-test-and-shutdown script will actually print that the test failed.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index a91ff834fe..cd1f2e892e 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -177,13 +177,6 @@ if (BUILD_LAGOM)
# FIXME: Only TestJSON needs this property
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/../../AK/Tests
)
-
- set_tests_properties(
- ${name}_lagom
- PROPERTIES
- FAIL_REGULAR_EXPRESSION
- "FAIL"
- )
endforeach()
foreach(source ${LIBREGEX_TESTS})
@@ -195,13 +188,6 @@ if (BUILD_LAGOM)
COMMAND ${name}_lagom
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
)
-
- set_tests_properties(
- ${name}_lagom
- PROPERTIES
- FAIL_REGULAR_EXPRESSION
- "FAIL"
- )
endforeach()
endif()
endif()