summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Woertz <simon@woertz.at>2021-11-21 20:24:19 +0100
committerLinus Groh <mail@linusgroh.de>2022-01-08 18:57:55 +0100
commit47f4e54cdc8c5aea81cbfc4a18a5ecb147a34a9c (patch)
tree934922537bf971a1c5d21357e17ce44d36850cd8 /Meta/Lagom/CMakeLists.txt
parentc857b5d22f7df94ef44a6a75bf1dd54d44491fab (diff)
downloadserenity-47f4e54cdc8c5aea81cbfc4a18a5ecb147a34a9c.zip
Lagom: Execute `LibPDF` unit tests on the host
Add lagom unit tests for `LibPDF`.
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index a4aa83d1b5..b953f079dc 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -548,6 +548,12 @@ if (BUILD_LAGOM)
lagom_test(${source} LIBS LagomGL)
endforeach()
+ # PDF
+ file(GLOB LIBPDF_TESTS CONFIGURE_DEPENDS "../../Tests/LibPDF/*.cpp")
+ foreach(source ${LIBPDF_TESTS})
+ lagom_test(${source} LIBS LagomPDF WORKING_DIRECTORY ${SERENITY_PROJECT_ROOT}/Base/home/anon/Documents/pdf/)
+ endforeach()
+
# Regex
file(GLOB LIBREGEX_TESTS CONFIGURE_DEPENDS "../../Tests/LibRegex/*.cpp")
# RegexLibC test POSIX <regex.h> and contains many Serenity extensions