summaryrefslogtreecommitdiff
path: root/Meta/Lagom/CMakeLists.txt
diff options
context:
space:
mode:
authorJan200101 <sentrycraft123@gmail.com>2022-12-06 22:57:20 +0100
committerAndrew Kaster <andrewdkaster@gmail.com>2022-12-12 21:34:09 -0700
commit10d40af16743df93de58e4d9fac51139b7e3130d (patch)
tree4f6c6e79612115ee4bd078c075b68c08f5e2d7e9 /Meta/Lagom/CMakeLists.txt
parent0bd9a94bea46bceefbc40b449ea761579a4b37a7 (diff)
downloadserenity-10d40af16743df93de58e4d9fac51139b7e3130d.zip
Meta: Separate ccache setup into its own component
Diffstat (limited to 'Meta/Lagom/CMakeLists.txt')
-rw-r--r--Meta/Lagom/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/Meta/Lagom/CMakeLists.txt b/Meta/Lagom/CMakeLists.txt
index 8fa1a117da..56cfcbe139 100644
--- a/Meta/Lagom/CMakeLists.txt
+++ b/Meta/Lagom/CMakeLists.txt
@@ -49,11 +49,7 @@ option(BUILD_SHARED_LIBS "Build shared libraries instead of static libraries" ON
find_package(Threads REQUIRED)
if (ENABLE_LAGOM_CCACHE)
- find_program(CCACHE_PROGRAM ccache)
- if(CCACHE_PROGRAM)
- set(CMAKE_C_COMPILER_LAUNCHER "${CCACHE_PROGRAM}" CACHE FILEPATH "Path to a compiler launcher program, e.g. ccache")
- set(CMAKE_CXX_COMPILER_LAUNCHER "${CCACHE_PROGRAM}" CACHE FILEPATH "Path to a compiler launcher program, e.g. ccache")
- endif()
+ include(setup_ccache)
endif()
if (ENABLE_FUZZERS_LIBFUZZER OR ENABLE_FUZZERS_OSSFUZZ)