summaryrefslogtreecommitdiff
path: root/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorLuke <luke.wilde@live.co.uk>2020-11-21 18:32:39 +0000
committerAndreas Kling <kling@serenityos.org>2020-11-22 18:20:56 +0100
commite8b3a6558191e97ffab28943865a9459f013969e (patch)
treed332303702f9ab31773668fac51b6b4a03dd4b47 /Libraries/LibWeb/CMakeLists.txt
parent819f099a8eb595689bc37933c10d2a4fdb7737b1 (diff)
downloadserenity-e8b3a6558191e97ffab28943865a9459f013969e.zip
LibWeb: Make event dispatching spec-compliant
Specification: https://dom.spec.whatwg.org/#concept-event-dispatch This also introduces shadow roots due to it being a requirement of the event dispatcher. However, it does not introduce the full shadow DOM, that can be left for future work. This changes some event dispatches which require certain attributes to be initialised to a value.
Diffstat (limited to 'Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Libraries/LibWeb/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Libraries/LibWeb/CMakeLists.txt b/Libraries/LibWeb/CMakeLists.txt
index f084378cd1..54aa0849ea 100644
--- a/Libraries/LibWeb/CMakeLists.txt
+++ b/Libraries/LibWeb/CMakeLists.txt
@@ -35,12 +35,14 @@ set(SOURCES
DOM/DOMImplementation.cpp
DOM/Element.cpp
DOM/ElementFactory.cpp
+ DOM/Event.cpp
DOM/EventDispatcher.cpp
DOM/EventListener.cpp
DOM/EventTarget.cpp
DOM/Node.cpp
DOM/ParentNode.cpp
DOM/Position.cpp
+ DOM/ShadowRoot.cpp
DOM/TagNames.cpp
DOM/Text.cpp
DOM/Text.idl
@@ -185,6 +187,7 @@ set(SOURCES
SVG/SVGSVGElement.cpp
SVG/TagNames.cpp
StylePropertiesModel.cpp
+ UIEvents/MouseEvent.cpp
URLEncoder.cpp
WebContentClient.cpp
)
@@ -237,6 +240,7 @@ libweb_js_wrapper(DOM/DOMImplementation)
libweb_js_wrapper(DOM/Element)
libweb_js_wrapper(DOM/Event)
libweb_js_wrapper(DOM/EventTarget)
+libweb_js_wrapper(DOM/ShadowRoot)
libweb_js_wrapper(DOM/Node)
libweb_js_wrapper(DOM/Text)
libweb_js_wrapper(HTML/CanvasRenderingContext2D)