summaryrefslogtreecommitdiff
path: root/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2020-06-04 16:06:32 +0200
committerAndreas Kling <kling@serenityos.org>2020-06-04 16:06:32 +0200
commit959de19418c831e1384f6d65a45971dd1d6a4287 (patch)
tree11799bded8de162b37feab50fd098aeb0b6a0a71 /Libraries/LibWeb/CMakeLists.txt
parentec1891837fd2aeec9b644ca1b70caf6f026e305a (diff)
downloadserenity-959de19418c831e1384f6d65a45971dd1d6a4287.zip
LibWeb: Process style sheets in document order
Until now we would simply apply stylesheets in the order they finished loading. This patch adds a StyleSheetList object that hangs off of each Document and contains all the style sheets in document order. There's still a lot of work to do for a proper cascade, but at least this makes us consistently wrong every time. :^)
Diffstat (limited to 'Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Libraries/LibWeb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Libraries/LibWeb/CMakeLists.txt b/Libraries/LibWeb/CMakeLists.txt
index 023a60be8b..02b98b3133 100644
--- a/Libraries/LibWeb/CMakeLists.txt
+++ b/Libraries/LibWeb/CMakeLists.txt
@@ -24,6 +24,7 @@ set(SOURCES
CSS/StyleResolver.cpp
CSS/StyleRule.cpp
CSS/StyleSheet.cpp
+ CSS/StyleSheetList.cpp
CSS/StyleValue.cpp
DOM/AttributeNames.cpp
DOM/CanvasRenderingContext2D.cpp