summaryrefslogtreecommitdiff
path: root/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2020-06-21 16:10:48 +0200
committerAndreas Kling <kling@serenityos.org>2020-06-21 16:12:28 +0200
commite1bd815a6a6f460738cd2e0206bb1f3deb77d0d2 (patch)
tree48821788571b24f186f181a0193dc9988d9f559f /Libraries/LibWeb/CMakeLists.txt
parentdd29ff884f5d303353b06f4e25fe2a1faf2dbd3c (diff)
downloadserenity-e1bd815a6a6f460738cd2e0206bb1f3deb77d0d2.zip
LibWeb: Generate Event and MouseEvent bindings from IDL :^)
We still have to hand-write a function to turn an Event& into a wrapper but this is still a hue improvement. Eventually we'll find a way to auto-generate that function as well.
Diffstat (limited to 'Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Libraries/LibWeb/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/Libraries/LibWeb/CMakeLists.txt b/Libraries/LibWeb/CMakeLists.txt
index a42b71585f..9c36c2cc49 100644
--- a/Libraries/LibWeb/CMakeLists.txt
+++ b/Libraries/LibWeb/CMakeLists.txt
@@ -1,9 +1,8 @@
set(SOURCES
Bindings/CanvasRenderingContext2DWrapper.cpp
Bindings/EventListenerWrapper.cpp
- Bindings/EventWrapper.cpp
+ Bindings/EventWrapperFactory.cpp
Bindings/LocationObject.cpp
- Bindings/MouseEventWrapper.cpp
Bindings/NavigatorObject.cpp
Bindings/NodeWrapperFactory.cpp
Bindings/WindowObject.cpp
@@ -158,6 +157,8 @@ libweb_js_wrapper(HTMLElement)
libweb_js_wrapper(HTMLImageElement)
libweb_js_wrapper(HTMLCanvasElement)
libweb_js_wrapper(ImageData)
+libweb_js_wrapper(Event)
+libweb_js_wrapper(MouseEvent)
get_property(WRAPPER_SOURCES GLOBAL PROPERTY wrapper_sources)
set(SOURCES ${SOURCES} ${WRAPPER_SOURCES})