summaryrefslogtreecommitdiff
path: root/Libraries/LibWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2020-06-22 21:41:10 +0200
committerAndreas Kling <kling@serenityos.org>2020-06-22 21:47:01 +0200
commit10255bc5c6664ffcb8b496c34a7c34b56d898138 (patch)
tree2aeed4e45c781c0bb14819839af2fa77e5b38b0a /Libraries/LibWeb/CMakeLists.txt
parentb273b31c7de6ad2d41e6498e34792d8a34b19feb (diff)
downloadserenity-10255bc5c6664ffcb8b496c34a7c34b56d898138.zip
LibWeb+Browser: Decode non-animated images out-of-process :^)
We now use the ImageDecoder service in LibWeb for everything except GIF images (we'll have to deal with them later, ofc.) This has a little bit of overhead but we should be able to optimize it until it becomes negligible.
Diffstat (limited to 'Libraries/LibWeb/CMakeLists.txt')
-rw-r--r--Libraries/LibWeb/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Libraries/LibWeb/CMakeLists.txt b/Libraries/LibWeb/CMakeLists.txt
index fb3cf7c7d0..c966491981 100644
--- a/Libraries/LibWeb/CMakeLists.txt
+++ b/Libraries/LibWeb/CMakeLists.txt
@@ -193,4 +193,4 @@ add_custom_command(
)
serenity_lib(LibWeb web)
-target_link_libraries(LibWeb LibCore LibJS LibMarkdown LibGemini LibGUI LibGfx LibTextCodec LibProtocol)
+target_link_libraries(LibWeb LibCore LibJS LibMarkdown LibGemini LibGUI LibGfx LibTextCodec LibProtocol LibImageDecoderClient)