summaryrefslogtreecommitdiff
path: root/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2020-06-06 01:14:10 +0100
committerAndreas Kling <kling@serenityos.org>2020-06-07 19:29:40 +0200
commit0ff9d7e1898c224033fde7b03ac9c92db893bfca (patch)
treebafbbc17fa7c6fdcc2b07c4c4e806f8bfc2eebaa /Libraries/LibJS/CMakeLists.txt
parent40829b849ae30d3a9de330d4d66af74f547fbaf1 (diff)
downloadserenity-0ff9d7e1898c224033fde7b03ac9c92db893bfca.zip
LibJS: Add BigInt
Diffstat (limited to 'Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Libraries/LibJS/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/Libraries/LibJS/CMakeLists.txt b/Libraries/LibJS/CMakeLists.txt
index c170fe908a..e2de6c97b4 100644
--- a/Libraries/LibJS/CMakeLists.txt
+++ b/Libraries/LibJS/CMakeLists.txt
@@ -8,9 +8,13 @@ set(SOURCES
Lexer.cpp
MarkupGenerator.cpp
Parser.cpp
- Runtime/ArrayConstructor.cpp
Runtime/Array.cpp
+ Runtime/ArrayConstructor.cpp
Runtime/ArrayPrototype.cpp
+ Runtime/BigInt.cpp
+ Runtime/BigIntConstructor.cpp
+ Runtime/BigIntObject.cpp
+ Runtime/BigIntPrototype.cpp
Runtime/BooleanConstructor.cpp
Runtime/BooleanObject.cpp
Runtime/BooleanPrototype.cpp
@@ -65,4 +69,4 @@ set(SOURCES
)
serenity_lib(LibJS js)
-target_link_libraries(LibJS LibM LibCore)
+target_link_libraries(LibJS LibM LibCore LibCrypto)