summaryrefslogtreecommitdiff
path: root/Libraries/LibJS/CMakeLists.txt
diff options
context:
space:
mode:
authormattco98 <matthewcolsson@gmail.com>2020-04-29 23:25:21 -0700
committerAndreas Kling <kling@serenityos.org>2020-05-17 18:05:15 +0200
commit4ced12670453df331632c980e7479159ef5ddf83 (patch)
treeea4131b65fc0d29c75821f103f8402e0bc5d14fb /Libraries/LibJS/CMakeLists.txt
parentb5b08fba9277f0c71e0561e89d36e9151cbe91d0 (diff)
downloadserenity-4ced12670453df331632c980e7479159ef5ddf83.zip
LibJS: Add symbol objects
This commit adds the following classes: SymbolObject, SymbolConstructor, SymbolPrototype, and Symbol. This commit does not introduce any new functionality to the Object class, so they cannot be used as property keys in objects.
Diffstat (limited to 'Libraries/LibJS/CMakeLists.txt')
-rw-r--r--Libraries/LibJS/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Libraries/LibJS/CMakeLists.txt b/Libraries/LibJS/CMakeLists.txt
index 11c4608282..d9928f9188 100644
--- a/Libraries/LibJS/CMakeLists.txt
+++ b/Libraries/LibJS/CMakeLists.txt
@@ -46,6 +46,10 @@ set(SOURCES
Runtime/StringConstructor.cpp
Runtime/StringObject.cpp
Runtime/StringPrototype.cpp
+ Runtime/Symbol.cpp
+ Runtime/SymbolConstructor.cpp
+ Runtime/SymbolObject.cpp
+ Runtime/SymbolPrototype.cpp
Runtime/Uint8ClampedArray.cpp
Runtime/Value.cpp
Token.cpp