summaryrefslogtreecommitdiff
path: root/Libraries/LibCore/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2020-09-15 21:33:37 +0200
committerAndreas Kling <kling@serenityos.org>2020-09-15 21:46:26 +0200
commite2f32b8f9d4ce0ce8f92d4817273fb9b32cd8ccd (patch)
treebcc49c2fd5a87ffbfc992d0b1406b4c64e47941b /Libraries/LibCore/CMakeLists.txt
parent1e96e46a8137e297d1d38271373145ac21f4da3e (diff)
downloadserenity-e2f32b8f9d4ce0ce8f92d4817273fb9b32cd8ccd.zip
LibCore: Make Core::Object properties more dynamic
Instead of everyone overriding save_to() and set_property() and doing a pretty asymmetric job of implementing the various properties, let's add a bit of structure here. Object properties are now represented by a Core::Property. Properties are registered with a getter and setter (optional) in constructors. I've added some convenience macros for creating and registering properties, but this does still feel a bit bulky. We'll have to iterate on this and see where it goes.
Diffstat (limited to 'Libraries/LibCore/CMakeLists.txt')
-rw-r--r--Libraries/LibCore/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Libraries/LibCore/CMakeLists.txt b/Libraries/LibCore/CMakeLists.txt
index bd64c35131..8b1dfd6059 100644
--- a/Libraries/LibCore/CMakeLists.txt
+++ b/Libraries/LibCore/CMakeLists.txt
@@ -19,6 +19,7 @@ set(SOURCES
Notifier.cpp
Object.cpp
ProcessStatisticsReader.cpp
+ Property.cpp
puff.cpp
SocketAddress.cpp
Socket.cpp