summaryrefslogtreecommitdiff
path: root/Ladybird/CMakeLists.txt
diff options
context:
space:
mode:
authorLinus Groh <mail@linusgroh.de>2022-10-22 23:35:55 +0200
committerAndrew Kaster <andrewdkaster@gmail.com>2022-12-25 07:58:58 -0700
commitc91978baa67e44f33bc1b0c1d1988b07147bdcda (patch)
tree2fb739c61a1a72bedea2b88608734c3bd40edfd7 /Ladybird/CMakeLists.txt
parentfb71dc51418905f8b35f7fbc3cf242236c723fc5 (diff)
downloadserenity-c91978baa67e44f33bc1b0c1d1988b07147bdcda.zip
Ladybird: Use Browser's CookieJar.{cpp,h}
There are no custom changes for Ladybird in the current copies of those files, so we just need to ensure to keep Ladybird up to date for any changes made upstream. This fixes a build issue introduced by https://github.com/SerenityOS/serenity/pull/15736.
Diffstat (limited to 'Ladybird/CMakeLists.txt')
-rw-r--r--Ladybird/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Ladybird/CMakeLists.txt b/Ladybird/CMakeLists.txt
index 0e84edfd7d..59b8702020 100644
--- a/Ladybird/CMakeLists.txt
+++ b/Ladybird/CMakeLists.txt
@@ -63,10 +63,12 @@ set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
find_package(Qt6 REQUIRED COMPONENTS Core Widgets Network)
+set(BROWSER_SOURCE_DIR ${SERENITY_SOURCE_DIR}/Userland/Applications/Browser/)
+
set(SOURCES
+ ${BROWSER_SOURCE_DIR}/CookieJar.cpp
BrowserWindow.cpp
ConsoleWidget.cpp
- CookieJar.cpp
History.cpp
ModelTranslator.cpp
Settings.cpp
@@ -84,6 +86,7 @@ qt_add_executable(ladybird ${SOURCES}
target_link_libraries(ladybird PRIVATE Qt::Widgets Qt::Network LibWeb LibWebSocket LibGUI LibWebView LibGL LibSoftGPU LibMain)
target_include_directories(ladybird PRIVATE ${CMAKE_CURRENT_BINARY_DIR})
+target_include_directories(ladybird PRIVATE ${SERENITY_SOURCE_DIR}/Userland/Applications/)
target_include_directories(ladybird PRIVATE ${SERENITY_SOURCE_DIR}/Userland/Services/)
set_target_properties(ladybird PROPERTIES