summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-02-24 11:30:19 +0100
committerAndreas Kling <kling@serenityos.org>2021-02-24 11:38:52 +0100
commitf27eb315fc65bd1ab37d1552dc0407d79e4ce833 (patch)
tree6e4226c061d45c308ef8d7952234b64bd80edfb7 /Kernel/CMakeLists.txt
parent0817ea01c2153a21582eb5a15cdb2a0ffaa8c9d5 (diff)
downloadserenity-f27eb315fc65bd1ab37d1552dc0407d79e4ce833.zip
Build: Build Userland with -O2, Kernel with -Os
For some reason I don't yet understand, building the kernel with -O2 produces a way-too-large kernel on some people's systems. Since there are some really nice performance benefits from -O2 in userspace, let's do a compromise and build Userland with -O2 but put Kernel back into the -Os box for now.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 7481682596..1096416806 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -1,3 +1,5 @@
+add_compile_options(-Os)
+
set(KERNEL_HEAP_SOURCES
Heap/SlabAllocator.cpp
Heap/kmalloc.cpp