summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2023-02-24 20:00:03 +0200
committerJelle Raaijmakers <jelle@gmta.nl>2023-06-04 21:32:34 +0200
commitf1cbfc5a6e9b6a60278fcbb3e9fa9b10e1f593e0 (patch)
tree53fe02612ed866af1bc27754731303c2244c2c57 /Kernel/CMakeLists.txt
parentee0ccdaebe617b7ff1536498dcf27ec3c17f60e1 (diff)
downloadserenity-f1cbfc5a6e9b6a60278fcbb3e9fa9b10e1f593e0.zip
Kernel: Move task-crash related code to the Tasks subdirectory
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 55449dc70c..57569be4d1 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -41,8 +41,6 @@ set(KERNEL_SOURCES
Bus/VirtIO/Queue.cpp
Bus/VirtIO/RNG.cpp
CommandLine.cpp
- Coredump.cpp
- CrashHandler.cpp
Devices/AsyncDeviceRequest.cpp
Devices/Audio/AC97.cpp
Devices/Audio/Channel.cpp
@@ -344,6 +342,8 @@ set(KERNEL_SOURCES
TTY/SlavePTY.cpp
TTY/TTY.cpp
TTY/VirtualConsole.cpp
+ Tasks/Coredump.cpp
+ Tasks/CrashHandler.cpp
Tasks/FinalizerTask.cpp
Tasks/FutexQueue.cpp
Tasks/Process.cpp