summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2023-02-20 17:51:18 +0200
committerLinus Groh <mail@linusgroh.de>2023-02-24 22:14:18 +0100
commitc56e1c53783ae0f2c7388160cf88c0c6b7c09081 (patch)
tree38046b7a448977b8fe22d3a22077373e786c2584 /Kernel/CMakeLists.txt
parent9216caeec20c41e96e969d8992d6a104649a94de (diff)
downloadserenity-c56e1c53783ae0f2c7388160cf88c0c6b7c09081.zip
Kernel/FileSystem: Simplify the ProcFS significantly
Since the ProcFS doesn't hold many global objects within it, the need for a fully-structured design of backing components and a registry like with the SysFS is no longer true. To acommodate this, let's remove all backing store and components of the ProcFS, so now it resembles what we had in the early days of ProcFS in the project - a mostly-static filesystem, with very small amount of kmalloc allocations needed. We still use the inode index mechanism to understand the role of each inode, but this is done in a much "static"ier way than before.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 8d1734e923..f880747190 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -141,9 +141,9 @@ set(KERNEL_SOURCES
FileSystem/Plan9FS/FileSystem.cpp
FileSystem/Plan9FS/Inode.cpp
FileSystem/Plan9FS/Message.cpp
- FileSystem/ProcFS/ComponentRegistry.cpp
FileSystem/ProcFS/FileSystem.cpp
FileSystem/ProcFS/Inode.cpp
+ FileSystem/ProcFS/ProcessExposed.cpp
FileSystem/RAMFS/FileSystem.cpp
FileSystem/RAMFS/Inode.cpp
FileSystem/SysFS/Component.cpp
@@ -255,10 +255,7 @@ set(KERNEL_SOURCES
Net/UDPSocket.cpp
PerformanceEventBuffer.cpp
Process.cpp
- ProcessExposed.cpp
- ProcessSpecificExposed.cpp
ProcessGroup.cpp
- ProcessProcFSTraits.cpp
Random.cpp
Scheduler.cpp
ScopedCritical.cpp