summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2022-09-03 10:25:33 +0300
committerLinus Groh <mail@linusgroh.de>2022-09-20 18:43:05 +0100
commitc50a81e93e7cf5ea3df8afc6801ccdc4f6ec0c8c (patch)
treef58651c49b3243b0894d4b26fbabbf391f9fec0e /Kernel/CMakeLists.txt
parent948be9674a057658badceb469df14a5e92d818ea (diff)
downloadserenity-c50a81e93e7cf5ea3df8afc6801ccdc4f6ec0c8c.zip
Kernel: Move x86-specific HID code to the Arch/x86 directory
The i8042 controller with its attached devices, the PS2 keyboard and mouse, rely on x86-specific IO instructions to work. Therefore, move them to the Arch/x86 directory to make it easier to omit the handling code of these devices.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index cb37e56307..ebb2ce04cb 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -62,13 +62,9 @@ set(KERNEL_SOURCES
Devices/SelfTTYDevice.cpp
Devices/SerialDevice.cpp
Devices/ZeroDevice.cpp
- Devices/HID/I8042Controller.cpp
Devices/HID/HIDManagement.cpp
Devices/HID/KeyboardDevice.cpp
Devices/HID/MouseDevice.cpp
- Devices/HID/PS2KeyboardDevice.cpp
- Devices/HID/PS2MouseDevice.cpp
- Devices/HID/VMWareMouseDevice.cpp
GlobalProcessExposed.cpp
Graphics/Bochs/DisplayConnector.cpp
Graphics/Bochs/GraphicsAdapter.cpp
@@ -339,6 +335,10 @@ if ("${SERENITY_ARCH}" STREQUAL "i686" OR "${SERENITY_ARCH}" STREQUAL "x86_64")
Arch/x86/Hypervisor/VMWareBackdoor.cpp
+ Arch/x86/ISABus/HID/PS2KeyboardDevice.cpp
+ Arch/x86/ISABus/HID/PS2MouseDevice.cpp
+ Arch/x86/ISABus/HID/VMWareMouseDevice.cpp
+ Arch/x86/ISABus/I8042Controller.cpp
Arch/x86/ISABus/IDEController.cpp
Arch/x86/PCI/Controller/HostBridge.cpp
Arch/x86/PCI/Initializer.cpp