summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorTimon Kruiper <timonkruiper@gmail.com>2023-02-22 23:32:00 +0100
committerAndrew Kaster <andrewdkaster@gmail.com>2023-04-03 20:01:28 -0600
commitc31dc82b172aa88d1b208ed4074e2e387f7ea9bc (patch)
tree89850f613f39b54c4e2c090291f0b53944c73a30 /Kernel/CMakeLists.txt
parent1f68ac600c7bd48dbd452f290373b0b97dedecda (diff)
downloadserenity-c31dc82b172aa88d1b208ed4074e2e387f7ea9bc.zip
Kernel: Move deferred call code into separate DeferredCallPool class
This allows us to share this code between the x86_64 and aarch64 build.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index eb2b580486..a94d124afa 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -18,6 +18,7 @@ set(KERNEL_HEAP_SOURCES
set(KERNEL_SOURCES
AddressSanitizer.cpp
Arch/PageFault.cpp
+ Arch/DeferredCallPool.cpp
Bus/PCI/Controller/HostController.cpp
Bus/PCI/Controller/MemoryBackedHostBridge.cpp
Bus/PCI/Controller/VolumeManagementDevice.cpp