summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2023-02-03 11:40:42 +0200
committerAndrew Kaster <andrewdkaster@gmail.com>2023-02-19 15:01:01 -0700
commitac4829cc501ca74d63c3d07d87128046ad5e9523 (patch)
treef12e3f41fc7aa0de93811cd210f27bbd53cbee54 /Kernel/CMakeLists.txt
parent9eab59c42b2662075a3eab13fe7aebf23e0c8234 (diff)
downloadserenity-ac4829cc501ca74d63c3d07d87128046ad5e9523.zip
Kernel/IntelGraphics: Move PLL handling code to a different file
Dealing with the specific details of how to program a PLL should be done in a separate file to ensure we can easily expand it to support future generations of the Intel graphics device.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index a9555d1e35..8d1734e923 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -80,6 +80,7 @@ set(KERNEL_SOURCES
Graphics/Intel/Plane/G33DisplayPlane.cpp
Graphics/Intel/Transcoder/AnalogDisplayTranscoder.cpp
Graphics/Intel/Transcoder/DisplayTranscoder.cpp
+ Graphics/Intel/Transcoder/PLL.cpp
Graphics/Intel/DisplayConnectorGroup.cpp
Graphics/Intel/NativeDisplayConnector.cpp
Graphics/Intel/NativeGraphicsAdapter.cpp