summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorIdan Horowitz <idan.horowitz@gmail.com>2021-04-02 17:53:31 +0300
committerAndreas Kling <kling@serenityos.org>2021-06-10 21:54:51 +0200
commita898e01d4dc93e281196971000b110d264351919 (patch)
treec850243b582f3d0e3136e39208b298f876d0cf09 /Kernel/CMakeLists.txt
parentde6d03227321c7f7f926d8a4e5898b29b5178e40 (diff)
downloadserenity-a898e01d4dc93e281196971000b110d264351919.zip
Kernel: Add driver for RTL8168 & RTL8111 NICs
These are pretty common on older LGA1366 & LGA1150 motherboards. NOTE: Since the registers datasheets for all versions of the chip besides versions 1 - 3 are still under NDAs i had to collect several "magical vendor constants" from the *BSD driver and the linux driver that i was not able to name verbosely, and as such these are labeled with the comment "vendor magic values".
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index e1cd0e4dac..cf8e73f4be 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -125,6 +125,7 @@ set(KERNEL_SOURCES
Net/NetworkingManagement.cpp
Net/NetworkTask.cpp
Net/RTL8139NetworkAdapter.cpp
+ Net/RTL8168NetworkAdapter.cpp
Net/Routing.cpp
Net/Socket.cpp
Net/TCPSocket.cpp