summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2022-09-03 08:15:32 +0300
committerLinus Groh <mail@linusgroh.de>2022-09-20 18:43:05 +0100
commit948be9674a057658badceb469df14a5e92d818ea (patch)
treeb534c264fbca02b478b17e73829ca989094787da /Kernel/CMakeLists.txt
parentbb6f61ee5d032877ea832611e1516db3489f44ad (diff)
downloadserenity-948be9674a057658badceb469df14a5e92d818ea.zip
Kernel: Don't compile ISA IDE controller code in non-x86 builds
The ISA IDE controller code makes sense to be compiled in a x86 build as it relies on access to the x86 IO space. For other architectures, we can just omit the code as there's no way we can use that code again. To ensure we can omit the code easily, we move it to the Arch/x86 directory.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 0752e2245e..cb37e56307 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -95,7 +95,6 @@ set(KERNEL_SOURCES
Storage/ATA/AHCI/InterruptHandler.cpp
Storage/ATA/GenericIDE/Controller.cpp
Storage/ATA/GenericIDE/Channel.cpp
- Storage/ATA/GenericIDE/ISAController.cpp
Storage/ATA/GenericIDE/PCIController.cpp
Storage/ATA/ATAController.cpp
Storage/ATA/ATADevice.cpp
@@ -340,6 +339,7 @@ if ("${SERENITY_ARCH}" STREQUAL "i686" OR "${SERENITY_ARCH}" STREQUAL "x86_64")
Arch/x86/Hypervisor/VMWareBackdoor.cpp
+ Arch/x86/ISABus/IDEController.cpp
Arch/x86/PCI/Controller/HostBridge.cpp
Arch/x86/PCI/Initializer.cpp
)