summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2021-03-05 14:23:08 +0200
committerAndreas Kling <kling@serenityos.org>2021-05-16 19:58:33 +0200
commit6a728e2d761601a9d21f2269e2febbfde55b3646 (patch)
tree5019dbb0de448bfa895d06818089ed765b047b59 /Kernel/CMakeLists.txt
parent8515a1c49d0442f7ce23faec2c27a336d32ce7d6 (diff)
downloadserenity-6a728e2d761601a9d21f2269e2febbfde55b3646.zip
Kernel: Introduce a new graphics subsystem
This new subsystem is replacing the old code that was used to create device nodes of framebuffer devices in /dev. This subsystem includes for now 3 roles: 1. GraphicsManagement singleton object that is used in the boot process to enumerate and initialize display devices. 2. GraphicsDevice(s) that are used to control the display adapter. 3. FramebufferDevice(s) that are used to control the device node in /dev. For now, we support the Bochs display adapter and any other generic VGA compatible adapter that was configured by the boot loader to a known and fixed resolution. Two improvements in the Bochs display adapter code are that we can support native bochs-display device (this device doesn't expose any VGA capabilities) and also that we use the MMIO region, to configure the device, instead of setting IO ports for such tasks.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 103ba80609..e0e6be75d8 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -27,12 +27,10 @@ set(KERNEL_SOURCES
CoreDump.cpp
DMI.cpp
Devices/AsyncDeviceRequest.cpp
- Devices/BXVGADevice.cpp
Devices/BlockDevice.cpp
Devices/CharacterDevice.cpp
Devices/Device.cpp
Devices/FullDevice.cpp
- Devices/MBVGADevice.cpp
Devices/MemoryDevice.cpp
Devices/NullDevice.cpp
Devices/PCSpeaker.cpp
@@ -52,6 +50,12 @@ set(KERNEL_SOURCES
Devices/HID/PS2KeyboardDevice.cpp
Devices/HID/PS2MouseDevice.cpp
Devices/HID/VMWareMouseDevice.cpp
+ Graphics/BochsFramebufferDevice.cpp
+ Graphics/BochsGraphicsAdapter.cpp
+ Graphics/FramebufferDevice.cpp
+ Graphics/GraphicsManagement.cpp
+ Graphics/RawFramebufferDevice.cpp
+ Graphics/VGACompatibleAdapter.cpp
Storage/Partition/DiskPartition.cpp
Storage/Partition/DiskPartitionMetadata.cpp
Storage/Partition/EBRPartitionTable.cpp