summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-07-25 18:37:11 +0200
committerAndreas Kling <kling@serenityos.org>2021-07-25 18:44:47 +0200
commit6a537ceef19b30ece416e4b159a55df85a8cc51e (patch)
treea6fea0469aeb3b121f9d40d8a04498f68fdedd7a /Kernel/CMakeLists.txt
parent9a701eafc4b339e7ecb2e991f920f9835cd576b7 (diff)
downloadserenity-6a537ceef19b30ece416e4b159a55df85a8cc51e.zip
Kernel: Remove ContiguousVMObject, let AnonymousVMObject do the job
We don't need an entirely separate VMObject subclass to influence the location of the physical pages. Instead, we simply allocate enough physically contiguous memory first, and then pass it to the AnonymousVMObject constructor that takes a span of physical pages.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 2efc36336a..9f4a4e96a8 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -255,7 +255,6 @@ set(KERNEL_SOURCES
VirtIO/VirtIOQueue.cpp
VirtIO/VirtIORNG.cpp
VM/AnonymousVMObject.cpp
- VM/ContiguousVMObject.cpp
VM/InodeVMObject.cpp
VM/MemoryManager.cpp
VM/PageDirectory.cpp