summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2021-06-23 00:24:25 +0300
committerAndreas Kling <kling@serenityos.org>2021-06-29 20:53:59 +0200
commit47149e625faf4c970155ec923a2701ac2756e2cd (patch)
treeed35f9ab7429afe3a54cc02330218ea5132dd255 /Kernel/CMakeLists.txt
parent7c87891c06e37f217b5fde17a3fc869306da659b (diff)
downloadserenity-47149e625faf4c970155ec923a2701ac2756e2cd.zip
Kernel/ProcFS: Split code into more separate files
Instead of using one file for the entire "backend" of the ProcFS data and metadata, we could split that file into two files that represent 2 logical chunks of the ProcFS exposed objects: 1. Global and inter-process information. This includes all fixed data in the root folder of the ProcFS, networking information and the bus folder. 2. Per-process information. This includes all dynamic data about a process that resides in the /proc/PID/ folder. This change makes it more easier to read the code and to change it, hence we do it although there's no technical benefit from it now :)
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index d073b6c8de..c3d5360e6b 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -58,6 +58,7 @@ set(KERNEL_SOURCES
Devices/HID/PS2KeyboardDevice.cpp
Devices/HID/PS2MouseDevice.cpp
Devices/HID/VMWareMouseDevice.cpp
+ GlobalProcessExposed.cpp
Graphics/Console/GenericFramebufferConsole.cpp
Graphics/Console/ContiguousFramebufferConsole.cpp
Graphics/Console/TextModeConsole.cpp
@@ -149,6 +150,7 @@ set(KERNEL_SOURCES
PerformanceEventBuffer.cpp
Process.cpp
ProcessExposed.cpp
+ ProcessSpecificExposed.cpp
ProcessGroup.cpp
RTC.cpp
Random.cpp