summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2022-04-22 09:44:31 +0300
committerAndreas Kling <kling@serenityos.org>2022-06-17 11:01:27 +0200
commit290eb53cb531021f41f30cd4abd38f8665d37460 (patch)
tree05ed20b8c87ec2ff2a175bff0b077eee83bec3a3 /Kernel/CMakeLists.txt
parentcba47509215c2fa7b4cdb08a19ecf31788b9d567 (diff)
downloadserenity-290eb53cb531021f41f30cd4abd38f8665d37460.zip
Kernel/SysFS: Stop cluttering the codebase with pieces of SysFS parts
Instead, start to put everything in one place to resemble the directory structure of the SysFS when actually using it.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 2e4bfe317c..13c75f1ae0 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -26,8 +26,6 @@ set(KERNEL_SOURCES
Bus/PCI/API.cpp
Bus/PCI/Device.cpp
Bus/PCI/Initializer.cpp
- Bus/PCI/SysFSPCI.cpp
- Bus/USB/SysFSUSB.cpp
Bus/USB/UHCI/UHCIController.cpp
Bus/USB/UHCI/UHCIRootHub.cpp
Bus/USB/USBConfiguration.cpp
@@ -144,16 +142,18 @@ set(KERNEL_SOURCES
FileSystem/Plan9FileSystem.cpp
FileSystem/ProcFS.cpp
FileSystem/SysFS.cpp
- FileSystem/SysFSComponent.cpp
+ FileSystem/SysFS/Component.cpp
+ FileSystem/SysFS/Subsystems/Bus/PCI/SysFSPCI.cpp
+ FileSystem/SysFS/Subsystems/Bus/USB/SysFSUSB.cpp
+ FileSystem/SysFS/Subsystems/Firmware/BIOS.cpp
+ FileSystem/SysFS/Subsystems/Firmware/Directory.cpp
+ FileSystem/SysFS/Subsystems/Firmware/PowerStateSwitch.cpp
FileSystem/TmpFS.cpp
FileSystem/VirtualFileSystem.cpp
Firmware/ACPI/Initialize.cpp
Firmware/ACPI/Parser.cpp
Firmware/Hypervisor/VMWareBackdoor.cpp
Firmware/MultiProcessor/Parser.cpp
- Firmware/BIOS.cpp
- Firmware/PowerStateSwitch.cpp
- Firmware/SysFSFirmware.cpp
FutexQueue.cpp
Interrupts/APIC.cpp
Interrupts/GenericInterruptHandler.cpp