summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2022-08-20 18:25:54 +0200
committerAndreas Kling <kling@serenityos.org>2022-08-20 18:32:50 +0200
commit122d7d95336e6ea82e92ddcefe6254d05bcfd194 (patch)
treeb08fc935e29b559d6cd8abbbff0eb9107e3b4f5f /Kernel/CMakeLists.txt
parentbec314611d19408047a14f14349af4abf2578730 (diff)
downloadserenity-122d7d95336e6ea82e92ddcefe6254d05bcfd194.zip
Kernel: Add Credentials to hold a set of user and group IDs
This patch adds a new object to hold a Process's user credentials: - UID, EUID, SUID - GID, EGID, SGID, extra GIDs Credentials are immutable and child processes initially inherit the Credentials object from their parent. Whenever a process changes one or more of its user/group IDs, a new Credentials object is constructed. Any code that wants to inspect and act on a set of credentials can now do so without worrying about data races.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 7157fa197b..b850dc3291 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -43,6 +43,7 @@ set(KERNEL_SOURCES
CMOS.cpp
CommandLine.cpp
Coredump.cpp
+ Credentials.cpp
Devices/AsyncDeviceRequest.cpp
Devices/Audio/AC97.cpp
Devices/Audio/Channel.cpp