summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Mintram <me@jamesrm.com>2021-10-13 19:21:24 +0100
committerLinus Groh <mail@linusgroh.de>2021-10-14 01:23:08 +0100
commitceb3328877697763987f8575737d111fb592fba3 (patch)
tree83461bffaa0af449469a889f4dbeed68b295e6bf /Kernel/CMakeLists.txt
parentab70268d61fcd906bdd2dbafa4a37987194af759 (diff)
downloadserenity-ceb3328877697763987f8575737d111fb592fba3.zip
Kernel: Fix all linker errors for Aarch64 build
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 84a1c6db71..f05ca13a0a 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -361,6 +361,9 @@ else()
Arch/aarch64/dummy.cpp
${AK_SOURCES}
)
+
+ # Otherwise linker errors e.g undefined reference to `__aarch64_cas8_acq_rel'
+ add_compile_options(-mno-outline-atomics)
endif()
add_compile_options(-fsigned-char)