summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorNico Weber <thakis@chromium.org>2020-08-25 19:19:16 -0400
committerAndreas Kling <kling@serenityos.org>2020-08-26 08:52:07 +0200
commitc85e679e2d802159f7eb1a70a1667dd20dea0379 (patch)
tree9b99e1274e82e67fc40f3bf06d8ef1162ed3afe0 /Kernel/CMakeLists.txt
parent2c1b84b3e10e67d6aeb3006f7535b8990355d769 (diff)
downloadserenity-c85e679e2d802159f7eb1a70a1667dd20dea0379.zip
AK+LibCore+Kernel: Have fewer implementations of day_of_year
The JS tests pointed out that the implementation in DateTime had an off-by-one in the month when doing the leap year check, so this change fixes that bug.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index ff9379d823..87befd7fc2 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -207,6 +207,7 @@ set(AK_SOURCES
../AK/StringImpl.cpp
../AK/StringUtils.cpp
../AK/StringView.cpp
+ ../AK/Time.cpp
)
set(ELF_SOURCES