summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2021-02-14 09:01:52 +0100
committerAndreas Kling <kling@serenityos.org>2021-02-14 09:36:58 +0100
commitc598a95b1c3b66cf1029eac2bcd88288c1fdb05f (patch)
tree5f7439e065146786075ce863b089be60083889a4 /Kernel/CMakeLists.txt
parentca35776e782a87981676906d99ff25d110077a3f (diff)
downloadserenity-c598a95b1c3b66cf1029eac2bcd88288c1fdb05f.zip
Kernel: Add a PANIC() function
Let's be a little more expressive when inducing a kernel panic. :^) PANIC(...) passes any arguments you give it to dmesgln(), then prints a backtrace and hangs the machine.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 26458c32a6..5059dde24b 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -101,6 +101,7 @@ set(KERNEL_SOURCES
PCI/IOAccess.cpp
PCI/Initializer.cpp
PCI/MMIOAccess.cpp
+ Panic.cpp
PerformanceEventBuffer.cpp
Process.cpp
ProcessGroup.cpp