summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2020-08-15 01:17:00 +0200
committerAndreas Kling <kling@serenityos.org>2020-08-15 01:30:22 +0200
commitbf247fb45f0c21121281609949e5891237721d62 (patch)
tree423446a042e224a4538022583403cbe062928888 /Kernel/CMakeLists.txt
parent5f3d38445412319d1a95454d1b51706fa055b210 (diff)
downloadserenity-bf247fb45f0c21121281609949e5891237721d62.zip
Kernel+LibC+UserspaceEmulator: Remove sys$dup() and sys$dup2()
We can just implement these in userspace, so yay two less syscalls!
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 43a9d4bc15..9743e146b2 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -100,7 +100,6 @@ set(KERNEL_SOURCES
Syscalls/clock.cpp
Syscalls/debug.cpp
Syscalls/disown.cpp
- Syscalls/dup.cpp
Syscalls/execve.cpp
Syscalls/exit.cpp
Syscalls/fcntl.cpp