summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2021-12-20 11:10:35 +0200
committerLinus Groh <mail@linusgroh.de>2022-01-23 00:38:02 +0000
commitb1ca39411b42b4164def6bf6f4e138e5ca7cffb0 (patch)
tree9ee7951e38dd4e5b8c3604e5bed2130c8fa6a584 /Kernel/CMakeLists.txt
parentb60e19fd3406dec707c4933d840286526e4058d1 (diff)
downloadserenity-b1ca39411b42b4164def6bf6f4e138e5ca7cffb0.zip
Kernel/Devices: Introduce the Device Control Device
This device will assist userspace to manage hotplug events. A userspace application reads a DeviceEvent entry until the return value is zero which indicates no events that are queued and waiting for processing. Trying to read with a buffer smaller than sizeof(DeviceEvent) results in EOVERFLOW. For now, there's no ioctl mechanism for this device but in the future an acknowledgement mechanism can be implemented via ioctl(2) interface.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index b887683496..c433b27fda 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -51,6 +51,7 @@ set(KERNEL_SOURCES
Devices/CharacterDevice.cpp
Devices/ConsoleDevice.cpp
Devices/Device.cpp
+ Devices/DeviceControlDevice.cpp
Devices/DeviceManagement.cpp
Devices/FullDevice.cpp
Devices/KCOVDevice.cpp