summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorTimon Kruiper <timonkruiper@gmail.com>2022-10-25 22:17:57 +0200
committerAndrew Kaster <andrewdkaster@gmail.com>2022-12-29 19:32:20 -0700
commitb18a7297c58a97fcfe501f7df0fb628125884278 (patch)
treecbe0ceb2a2ba3812f9857472ba58cf762cb1198c /Kernel/CMakeLists.txt
parent496a3cdcd300417e24bd520a0e0e603219544a22 (diff)
downloadserenity-b18a7297c58a97fcfe501f7df0fb628125884278.zip
Kernel: Move ScopedCritical.cpp to Kernel base directory
This file does not contain any architecture specific implementations, so we can move it to the Kernel base directory. Also update the relevant include paths.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 64f3446983..a14c4cc833 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -260,6 +260,7 @@ set(KERNEL_SOURCES
ProcessProcFSTraits.cpp
Random.cpp
Scheduler.cpp
+ ScopedCritical.cpp
StdLib.cpp
Syscalls/anon_create.cpp
Syscalls/alarm.cpp
@@ -390,7 +391,6 @@ if ("${SERENITY_ARCH}" STREQUAL "x86_64")
Arch/x86_64/VGA/IOArbiter.cpp
Arch/x86_64/RTC.cpp
- Arch/x86_64/ScopedCritical.cpp
Arch/x86_64/Shutdown.cpp
Arch/x86_64/SmapDisabler.cpp
@@ -466,7 +466,6 @@ elseif("${SERENITY_ARCH}" STREQUAL "aarch64")
Arch/aarch64/Panic.cpp
Arch/aarch64/Processor.cpp
Arch/aarch64/SafeMem.cpp
- Arch/aarch64/ScopedCritical.cpp
Arch/aarch64/SmapDisabler.cpp
Arch/aarch64/vector_table.S
)