summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2022-10-21 18:40:53 +0300
committerLinus Groh <mail@linusgroh.de>2022-10-22 19:18:15 +0200
commit97f8927da6bcfe6a84fb68b06377eb897cc49446 (patch)
tree398ed1509db4d120f38090983cf074fecc48c601 /Kernel/CMakeLists.txt
parent4c15915e408eb12144204bcf6aa006f57f1389cd (diff)
downloadserenity-97f8927da6bcfe6a84fb68b06377eb897cc49446.zip
Kernel: Remove the DevTmpFS class
Although this code worked quite well, it is considered to be a code duplication with the TmpFS code which is more tested and works quite well for a variety of cases. The only valid reason to keep this filesystem was that it enforces that no regular files will be created at all in the filesystem. Later on, we will re-introduce this feature in a sane manner. Therefore, this can be safely removed after SystemServer no longer uses this filesystem type anymore.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index eb7b98d8b3..6f6b9daa09 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -109,7 +109,6 @@ set(KERNEL_SOURCES
FileSystem/BlockBasedFileSystem.cpp
FileSystem/Custody.cpp
FileSystem/DevPtsFS.cpp
- FileSystem/DevTmpFS.cpp
FileSystem/Ext2FileSystem.cpp
FileSystem/FATFileSystem.cpp
FileSystem/FIFO.cpp