summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2021-03-13 12:01:44 +0200
committerAndreas Kling <kling@serenityos.org>2021-06-29 20:53:59 +0200
commit92c0dab5ab45ff0db8317439ea2f8bc3d96158c4 (patch)
treec2f13dc2ba91ebef415d3369867836eb4256b0ca /Kernel/CMakeLists.txt
parentdc6defa7af6ee0a4fe9331bf46311ba29f3df01b (diff)
downloadserenity-92c0dab5ab45ff0db8317439ea2f8bc3d96158c4.zip
Kernel: Introduce the new SysFS
The intention is to add dynamic mechanism for notifying the userspace about hotplug events. Currently, the DMI (SMBIOS) blobs and ACPI tables are exposed in the new filesystem.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index d991bac2e9..9652fbace8 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -30,7 +30,6 @@ set(KERNEL_SOURCES
CommandLine.cpp
ConsoleDevice.cpp
CoreDump.cpp
- DMI.cpp
Devices/AsyncDeviceRequest.cpp
Devices/BlockDevice.cpp
Devices/CharacterDevice.cpp
@@ -107,6 +106,7 @@ set(KERNEL_SOURCES
FileSystem/InodeWatcher.cpp
FileSystem/Plan9FileSystem.cpp
FileSystem/ProcFS.cpp
+ FileSystem/SysFS.cpp
FileSystem/TmpFS.cpp
FileSystem/VirtualFileSystem.cpp
FutexQueue.cpp
@@ -225,6 +225,7 @@ set(KERNEL_SOURCES
Syscalls/waitid.cpp
Syscalls/inode_watcher.cpp
Syscalls/write.cpp
+ SystemExposed.cpp
TTY/ConsoleManagement.cpp
TTY/MasterPTY.cpp
TTY/PTYMultiplexer.cpp