summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorLiav A <liavalb@gmail.com>2021-11-13 10:19:31 +0200
committerAndreas Kling <kling@serenityos.org>2021-11-13 10:05:22 +0100
commit4dc3617f3c1e35a8865fb1d26b2779959e6423fc (patch)
tree6d36ba5cfd62453d1b39158fbd6e9f8e5043bb1f /Kernel/CMakeLists.txt
parent648a139af36d6803fbe0674d4c6d461f46564e84 (diff)
downloadserenity-4dc3617f3c1e35a8865fb1d26b2779959e6423fc.zip
Kernel/Storage: Move all ATA related code to a new subdirectory
Like what happened with the PCI and USB code, this feels like the right thing to do because we can improve on the ATA capabilities and keep it distinguished from the rest of the subsystem.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index 385f6a5d07..e0f4a050a2 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -82,6 +82,15 @@ set(KERNEL_SOURCES
Graphics/VGACompatibleAdapter.cpp
Graphics/GenericFramebufferDevice.cpp
SanCov.cpp
+ Storage/ATA/AHCIController.cpp
+ Storage/ATA/AHCIPort.cpp
+ Storage/ATA/AHCIPortHandler.cpp
+ Storage/ATA/ATADevice.cpp
+ Storage/ATA/ATADiskDevice.cpp
+ Storage/ATA/ATAPIDiscDevice.cpp
+ Storage/ATA/BMIDEChannel.cpp
+ Storage/ATA/IDEController.cpp
+ Storage/ATA/IDEChannel.cpp
Storage/Partition/DiskPartition.cpp
Storage/Partition/DiskPartitionMetadata.cpp
Storage/Partition/EBRPartitionTable.cpp
@@ -89,15 +98,6 @@ set(KERNEL_SOURCES
Storage/Partition/MBRPartitionTable.cpp
Storage/Partition/PartitionTable.cpp
Storage/StorageDevice.cpp
- Storage/AHCIController.cpp
- Storage/AHCIPort.cpp
- Storage/AHCIPortHandler.cpp
- Storage/ATADevice.cpp
- Storage/ATADiskDevice.cpp
- Storage/ATAPIDiscDevice.cpp
- Storage/BMIDEChannel.cpp
- Storage/IDEController.cpp
- Storage/IDEChannel.cpp
Storage/RamdiskController.cpp
Storage/RamdiskDevice.cpp
Storage/StorageManagement.cpp