summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorSahan Fernando <sahan.h.fernando@gmail.com>2021-06-12 22:30:05 +1000
committerAndreas Kling <kling@serenityos.org>2021-06-25 19:26:30 +0200
commit34e9fa4d3be0284ac120e885ab920bb6024e4f04 (patch)
tree93f68ce4b61cb50f7440d4558b969d8f23341b2a /Kernel/CMakeLists.txt
parentcf1c8eb77862b9ef489619c73d16ace92b0aedf9 (diff)
downloadserenity-34e9fa4d3be0284ac120e885ab920bb6024e4f04.zip
Kernel: Abstract FramebufferConsole away from contiguous physical range
Currently, Kernel::Graphics::FramebufferConsole is written assuming that the underlying framebuffer memory exists in physically contiguous memory. There are a bunch of framebuffer devices that would need to use the components of FramebufferConsole (in particular access to the kernel bitmap font rendering logic). To reduce code duplication, framebuffer console has been split into two parts, the abstract GenericFramebufferConsole class which does the rendering, and the ContiguousFramebufferConsole class which contains all logic related to managing the underling vm object. Also, a new flush method has been added to the class, to support devices that require an extra flush step to render.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index e8fdefd60d..a63f17018b 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -59,7 +59,8 @@ set(KERNEL_SOURCES
Devices/HID/PS2KeyboardDevice.cpp
Devices/HID/PS2MouseDevice.cpp
Devices/HID/VMWareMouseDevice.cpp
- Graphics/Console/FramebufferConsole.cpp
+ Graphics/Console/GenericFramebufferConsole.cpp
+ Graphics/Console/ContiguousFramebufferConsole.cpp
Graphics/Console/TextModeConsole.cpp
Graphics/Console/VGAConsole.cpp
Graphics/BochsGraphicsAdapter.cpp