summaryrefslogtreecommitdiff
path: root/Kernel/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Kling <kling@serenityos.org>2020-12-25 02:14:56 +0100
committerAndreas Kling <kling@serenityos.org>2020-12-25 02:14:56 +0100
commit1e4c01064351d2f8ce3d55a173c5022d2601ad40 (patch)
tree07397a8f13d69ea15a191a0a16e58cedd35d8a10 /Kernel/CMakeLists.txt
parent7551a66f738ccd5f3f78e25493b46479ad50851d (diff)
downloadserenity-1e4c01064351d2f8ce3d55a173c5022d2601ad40.zip
LibELF: Remove ELF::Loader and move everyone to ELF::Image
This commit gets rid of ELF::Loader entirely since its very ambiguous purpose was actually to load executables for the kernel, and that is now handled by the kernel itself. This patch includes some drive-by cleanup in LibDebug and CrashDaemon enabled by the fact that we no longer need to keep the ref-counted ELF::Loader around.
Diffstat (limited to 'Kernel/CMakeLists.txt')
-rw-r--r--Kernel/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/Kernel/CMakeLists.txt b/Kernel/CMakeLists.txt
index c5497e7303..8ac692e840 100644
--- a/Kernel/CMakeLists.txt
+++ b/Kernel/CMakeLists.txt
@@ -224,7 +224,6 @@ set(AK_SOURCES
set(ELF_SOURCES
../Libraries/LibELF/Image.cpp
- ../Libraries/LibELF/Loader.cpp
../Libraries/LibELF/Validation.cpp
)